Is the i-FlashDrive app compatible with older iOS version?

The i-FlashDrive ONE app will run on iOS 7 or later.

Have more questions? Submit a request

Comments

Powered by Zendesk